Recently, you may have received an email from Alberta Health Services regarding upgrade requirements for remote users of Alberta Netcare.

Microquest has tested and verified that the latest version of Citrix Receiver (version 4.12 or greater) works with Healthquest and Netcare.  

To check if your clinic requires this upgrade, Microquest recommends contacting your hardware vendor to verify your Citrix Receiver version and ensure the upgrade is completed prior to the email’s stated April 18th deadline.

If you have any questions regarding this upgrade, do not hesitate to contact Microquest support